use strict;
my $str = 'if ( antrag . frage ( \'vNamen\' ) . istBeantwortet ( ) ) {
antrag.istHauptantrag() ;
} else if (antrag . istAntragGleich ( \'a0001\' ) || antrag . istWiederholungsantrag ( ) ) {
antrag.frage(\'vNamen\').feld(\'name\').laenge() > 0;
} else {
true;
}';
my $regex = qr/\/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";