$re = '/^([^_]+)(?:_([^.]+))?\.(.+)$/m';
$str = 'main_opt.otherstuff
main.otherstuff';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);