re = /\|[ ]?(a|b|d|f|j|k|m)([ ]*\=[ ]*)((?![\r\n]+\|)[0-9a-zA-Z, \[\]:\|\r\n\t])+/
str = '{{TemplateX
| a =
Foo bar
Blah blah
Fizbin foo
Ipsum lorem
|b =1
|c = 0fillertext
|d = 1alphabet
| e =
| f = 10: One
Hobbit
| g = aaaa, bbbb,
cccc,
dddd
|h = 15000
|i = -15000
| j = Level 4 [[domain:filk|Songs]]
| k =7 fizbin, 8 [[domain:trekkies|Shatners]]
|l =
|m =
}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end