import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(The law\\s+\\w+\\s\\P{Lu}*)(\\p{Lu}.*?)(?=The law|$)";
final String string = "The law of Huxley Something interesting. Some other interesting thing. The law of Dallas This thing is boring.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}