const regex = /(The law\s+\w+\s\P{Lu}*)(\p{Lu}.*?)(?=The law|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(The law\\s+\\w+\\s\\P{Lu}*)(\\p{Lu}.*?)(?=The law|$)', 'gm')
const str = `The law of Huxley Something interesting. Some other interesting thing. The law of Dallas This thing is boring.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}