re = /(?P<number>\d+)\s+(?P<Item_Name>\w+)\s+(?P<code>[a-zA-Z]{0,3})\s+(?P<status>SOLD|SALE|PURCHASED)/
str = '99 ITEM SEC SALE'
# Print the match result
str.match(re) do |match|
puts match.to_s
end