// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((?:[a-zA-Z0-9]{2}[:-]){5}[a-zA-Z0-9]{2})").unwrap();
let string = "Jul 11 18:09:06 ? user.info shepherd[366]: fifo: 8C:C1:21:A2:44:A3 is being marked undiscovered from state IS_IM_UNDELIV_DEST_UNDISC_MARKER_CLEAR by port removal";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}