#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\w+(?:[.-]\w+)*\.(?:ly|org|com|cc)\b"
Local $sString = "https://www.amazon.com/Technology-Ventures-Enterprise-Thomas-Byers/dp/0073523429" & @CRLF & _
"http://www.interactivedynamicvideo.com/" & @CRLF & _
"http://www.nytimes.com/2007/11/07/movies/07stein.html?_r=0" & @CRLF & _
"http://evonomics.com/advertising-cannot-maintain-internet-heres-solution/" & @CRLF & _
"HTTPS://github.com/keppel/pinn" & @CRLF & _
"Http://phys.org/news/2015-09-scale-solar-youve.html" & @CRLF & _
"https://iot.seeed.cc" & @CRLF & _
"http://www.bfilipek.com/2016/04/custom-deleters-for-c-smart-pointers.html" & @CRLF & _
"http://beta.crowdfireapp.com/?beta=agnipath" & @CRLF & _
"https://www.valid.ly?param" & @CRLF & _
"http://css-cursor.techstream.org"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")