using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+(?:[.-]\w+)*\.(?:ly|org|com|cc)\b";
string input = @"https://www.amazon.com/Technology-Ventures-Enterprise-Thomas-Byers/dp/0073523429
http://www.interactivedynamicvideo.com/
http://www.nytimes.com/2007/11/07/movies/07stein.html?_r=0
http://evonomics.com/advertising-cannot-maintain-internet-heres-solution/
HTTPS://github.com/keppel/pinn
Http://phys.org/news/2015-09-scale-solar-youve.html
https://iot.seeed.cc
http://www.bfilipek.com/2016/04/custom-deleters-for-c-smart-pointers.html
http://beta.crowdfireapp.com/?beta=agnipath
https://www.valid.ly?param
http://css-cursor.techstream.org";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}