import Foundation
let pattern = #"\w+(?:[.-]\w+)*\.(?:ly|org|com|cc)\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://www.amazon.com/Technology-Ventures-Enterprise-Thomas-Byers/dp/0073523429
http://www.interactivedynamicvideo.com/
http://www.nytimes.com/2007/11/07/movies/07stein.html?_r=0
http://evonomics.com/advertising-cannot-maintain-internet-heres-solution/
HTTPS://github.com/keppel/pinn
Http://phys.org/news/2015-09-scale-solar-youve.html
https://iot.seeed.cc
http://www.bfilipek.com/2016/04/custom-deleters-for-c-smart-pointers.html
http://beta.crowdfireapp.com/?beta=agnipath
https://www.valid.ly?param
http://css-cursor.techstream.org
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)