$re = '/(text)(?!<\/a>)/m';
$str = 'this is sample text about something what is text.
this is sample <a href=\'somelink.php\'>text</a> about something what is <a href=\'somelink.php\'>text</a>.';
$subst = "<a href='somelink.php'>$1</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;