#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)\b[\w\.-]+@((?!gmail|yahoo|hotmail).)[\w\.-]+\.\w{2,7}\b" & @CRLF & _
""
Local $sString = "asdfas@hotmail.com" & @CRLF & _
"gdfa@gmail.com" & @CRLF & _
"edenp@techday.com" & @CRLF & _
"asdfasdf@dasfdas.dofdfdf" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")