using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[\w\.-]+@((?!gmail|yahoo|hotmail).)[\w\.-]+\.\w{2,7}\b
";
string input = @"asdfas@hotmail.com
gdfa@gmail.com
edenp@techday.com
asdfasdf@dasfdas.dofdfdf
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}