$re = '/\b[\w\.-]+@((?!gmail|yahoo|hotmail).)[\w\.-]+\.\w{2,7}\b
/mi';
$str = 'asdfas@hotmail.com
gdfa@gmail.com
edenp@techday.com
asdfasdf@dasfdas.dofdfdf
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);