\ba Unicode word boundary
+matches at least one character from the set below:
\wa Unicode word character
\.the literal . (4610 / 568 / 2E16)
-the literal - (4510 / 558 / 2D16)
@the literal @ (6410 / 1008 / 4016)
Group 1((?!gmail|yahoo|hotmail).) Negative Lookahead(?!gmail|yahoo|hotmail) gmailthe literal text gmail (case insensitive) yahoothe literal text yahoo (case insensitive) hotmailthe literal text hotmail (case insensitive) .any Unicode character (except for line terminators)
+matches at least one character from the set below:
\wa Unicode word character
\.the literal . (4610 / 568 / 2E16)
-the literal - (4510 / 558 / 2D16)
\.the literal . (4610 / 568 / 2E16)
\w{2,7}a Unicode word character, repeated between 2 and 7 times
\ba Unicode word boundary
the literal ↵ (1010 / 128 / A16)
g modifier: global. Finds all matches instead of stopping after the first
m modifier: multiline. Causes ^ and $ to match the start and end of each line, not only the start and end of the string
i modifier: insensitive. Matches without distinguishing uppercase and lowercase letters