package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((a|a a)+)$`)
var str = `aaaaa
aa aa a`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}