import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?=.*\\b5[15]00\\b)[0-9]{2,}\\\\[0-9]{2}-[0-9]{4}-[0-9]{3}-|(?!.*\\b5[15]00\\b)[0-9]{2,}\\\\[0-9]{2}-[0-9]{4}-[0-9]{3}-[0-9]{2})$";
final String string = "01\\01-5500-000-\n"
+ "01\\01-5000-000-00";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}