#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)^\d.*?\b\d{5}$"
Local $sString = "asf aSD ikugfr jddc ghddfj gjn dfxg " & @CRLF & _
"sdgal fghfh 16 rgjodrisgj frth fghsdf," & @CRLF & _
"dfghdf dfhgdh gho h ghdof 67676" & @CRLF & _
"" & @CRLF & _
"szdgfads" & @CRLF & _
"2 adf dojosd hsh fghs, " & @CRLF & _
"zfgdf dhgdzsfb dfgdz," & @CRLF & _
"dzgdzfvg 47564" & @CRLF & _
"" & @CRLF & _
"asdgasdg asdg" & @CRLF & _
"4334 ersga errr ertgerfd ertera erers qereadf erfesfdc wefadfe, " & @CRLF & _
"sfsdgfg-43647" & @CRLF & _
"" & @CRLF & _
"2 adf dojosd hsh fghs, " & @CRLF & _
"zfgdf dhgdzsfb dfgdz," & @CRLF & _
"dzgdzfvg and more than 5 digits here 11147564"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")