package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)^\d.*?\b\d{5}$`)
var str = `asf aSD ikugfr jddc ghddfj gjn dfxg
sdgal fghfh 16 rgjodrisgj frth fghsdf,
dfghdf dfhgdh gho h ghdof 67676
szdgfads
2 adf dojosd hsh fghs,
zfgdf dhgdzsfb dfgdz,
dzgdzfvg 47564
asdgasdg asdg
4334 ersga errr ertgerfd ertera erers qereadf erfesfdc wefadfe,
sfsdgfg-43647
2 adf dojosd hsh fghs,
zfgdf dhgdzsfb dfgdz,
dzgdzfvg and more than 5 digits here 11147564`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}