import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((1?\\d(?::\\d\\d)?(?: [ap]\\.m\\.)?)(?:-(?2))?)";
final String string = "9:30-11 a.m. asdflkj; 12-8 p.m. 2:30-4:30 p.m. as;dlfkj 8 p.m. asdf;lkj 7-11 p.m. 11 a.m.-1 p.m. asd;lfkj 11 a.m. asd;flkj 7-10:30 p.m. and 8 p.m.-12 a.m.\n\n"
+ "asdf;lkj 12:30-2:30 p.m. a;lsdfj 12:15 p.m. a;ljkf 7 p.m.-12 a.m. 9:30-11:30 a.m.\n\n"
+ "8:00 a.m.-12:45 p.m.";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}