import Foundation
let pattern = #"((1?\d(?::\d\d)?(?: [ap]\.m\.)?)(?:-(?2))?)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
9:30-11 a.m. asdflkj; 12-8 p.m. 2:30-4:30 p.m. as;dlfkj 8 p.m. asdf;lkj 7-11 p.m. 11 a.m.-1 p.m. asd;lfkj 11 a.m. asd;flkj 7-10:30 p.m. and 8 p.m.-12 a.m.
asdf;lkj 12:30-2:30 p.m. a;lsdfj 12:15 p.m. a;ljkf 7 p.m.-12 a.m. 9:30-11:30 a.m.
8:00 a.m.-12:45 p.m.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)