import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:trGet|tr|trGetAndEscapeSingleQuotes)\\(('|\")((.|\\n)+?[^\\\\])\\1(?:\\,|\\))";
final String string = "trGet(\"blaa1\");\n\n"
+ "tr(\"blaaa\");\n\n"
+ "trGet(\"blaasdas's \");\n\n\n"
+ "trGet('single quote');\n\n\n"
+ "tr(\"matches\");\n\n"
+ "trGetAndEscapeSingleQuotes(\"multiline \n\n"
+ "mit 'single line' quote drin\n\n"
+ "hier\");\n\n"
+ "trGet(\"so hier mit backslash\\\", funtzt auch\");";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}