re = /(?:trGet|tr|trGetAndEscapeSingleQuotes)\(('|")((.|\n)+?[^\\])\1(?:\,|\))/im
str = 'trGet("blaa1");
tr("blaaa");
trGet("blaasdas\'s ");
trGet(\'single quote\');
tr("matches");
trGetAndEscapeSingleQuotes("multiline
mit \'single line\' quote drin
hier");
trGet("so hier mit backslash\\", funtzt auch");'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end