#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^((?:[^+\n]*\+){7})\d{8}(?=\+(?:\d{8})?\+)"
Local $sString = "UNA:+,? '" & @CRLF & _
"UNB+UNOC:3+000000000+000000000+20190801:1115+00001+DDMP190001'" & @CRLF & _
"UNH+00001+BRKE:01+00+0'" & @CRLF & _
"INV+ED Format 1+Brustkrebs+19880117+E000000001+20080702+++1+0'" & @CRLF & _
"FAL+087897044+0000000++Trägername+000000000+0+20080702++1+++J+N+N+N+N+N+++0'" & @CRLF & _
"INL+181095200+385762115+++0'" & @CRLF & _
"BEE+20080702++++0'" & @CRLF & _
"BAA+++J+J++++++J+++++++J++0'" & @CRLF & _
"BBA++++++++J++++++J+J++++++J+++++J+++J+J++++++++J+0'" & @CRLF & _
"BHP+J+++++J+++++J+++++0'" & @CRLF & _
"BLA+++J+++++++++0'" & @CRLF & _
"BFA++++++++++++J++0'" & @CRLF & _
"BSA++J+++J+J+++0'" & @CRLF & _
"BAT+20190801+0'" & @CRLF & _
"DAT+20080702++++0'" & @CRLF & _
"UNT+000014+00001'" & @CRLF & _
"UNZ+00001+00001'" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "\g<1>20200101"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)