re = /.*^(?=.{8,20})(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9]).*$/m
str = 'adeffk3535
Abjdf83894'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end