using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(8 6)\d{2} \d{2} \d{3}";
string input = @"8 650 51 210 ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}