# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[{]?[0-9a-fA-F]{8}[-]?([0-9a-fA-F]{4}[-]?){3}[0-9a-fA-F]{12}[}]?$"
test_str = ("8be94c81-a218-42f5-bf1b-383f15490d42\n"
"0C885DD3-7DD9-484B-9B20-3E6552BCA144\n"
"{0C885DD3-7DD9-484B-9B20-3E6552BCA144}\n"
"0C885DD37DD9484B9B203E6552BCA144\n"
"{0C885DD3-7DD9-484B-9B20-1E6552BCA144}\n"
"0C885DD3-7DD9484B9B203E6552BCA144\n"
"0C885DD37DD9484B9B203E6552BCA14")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.