using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!://)www\.";
string substitution = @"http://www.";
string input = @"http://www.dddd.com
www.new.com";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}