re = /(?<!:\/\/)www\./
str = 'http://www.dddd.com
www.new.com'
subst = 'http://www.'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result