using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w*)lan(\w+)";
string substitution = @"$1<--->$2";
string input = @"plan plans lander planitia";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}