const regex = /(\w*)lan(\w+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w*)lan(\\w+)', 'g')
const str = `plan plans lander planitia`;
const subst = `$1<--->$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);