use strict;
my $str = 'plan plans lander planitia';
my $regex = qr/(\w*)lan(\w+)/p;
my $subst = '$1<--->$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";