re = /(\w*)lan(\w+)/
str = 'plan plans lander planitia'
subst = '$1<--->$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result