import Foundation
let pattern = #"(\w*)lan(\w+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"plan plans lander planitia"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1<--->$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)