import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}) - - \\[(\\d{2}\\/[a-zA-Z]{3}\\/\\d{4}:\\d{2}:\\d{2}:\\d{2} (\\+|\\-)\\d{4})\\] ((\\\"(GET|POST|HEAD|OPTIONS) )(.+)(HTTP\\/1\\.(1|0)\")) (\\d{3}) (\\d+) ([\"]((\\-)|(.+))[\"]) ([\"](.+)[\"])";
final String string = "127.0.0.1 - - [19/Jan/2016:15:27:37 +0200] \"GET / HTTP/1.1\" 304 0 \"-\" \"Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.111 Safari/537.36\"\n"
+ "127.0.0.1 - - [19/Jan/2016:15:27:37 +0200] \"GET / HTTP/1.1\" 304 0 \"-\" \"Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.111 Safari/537.36\"\n"
+ "127.0.0.1 - - [19/Jan/2016:15:27:40 +0200] \"GET /asd HTTP/1.1\" 404 570 \"-\" \"Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.111 Safari/537.36\"\n"
+ "127.0.0.1 - - [19/Jan/2016:15:27:44 +0200] \"GET /asd HTTP/1.1\" 404 570 \"-\" \"Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.111 Safari/537.36\"\n"
+ "127.0.0.1 - - [19/Jan/2016:15:27:45 +0200] \"GET /asd HTTP/1.1\" 404 570 \"-\" \"Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.111 Safari/537.36\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}