# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=^.)O|(?<=^.{3})O|(?<=^.{5})O/0/g;t' <<< "AOAOAO
O1A1O1"