#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<=^.)O|(?<=^.{3})O|(?<=^.{5})O"
Local $sString = "AOAOAO" & @CRLF & _
"O1A1O1"
Local $sSubst = "0"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)