using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^.)O|(?<=^.{3})O|(?<=^.{5})O";
string substitution = @"0";
string input = @"AOAOAO
O1A1O1";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}