use strict;
my $str = 'AOAOAO
O1A1O1';
my $regex = qr/(?<=^.)O|(?<=^.{3})O|(?<=^.{5})O/p;
my $subst = '0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";