import Foundation
let pattern = #"(?<=^.)O|(?<=^.{3})O|(?<=^.{5})O"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
AOAOAO
O1A1O1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)