$re = '/[a-zA-Z0-9α-ωΑ-Ω]*/';
$str = 'Η σελίδα αυτή είναι απαÏαίτητη για να δημοσιεÏσετε Îνα σχόλιο. Και δεν Îχει οÏτε τώÏα ή Ï€Ïόκειται να θÎλετε να Ïυθμίσετε το παιχνίδι μου πολλά. Στην παÏοχή συμβουλών στους ασθενείς σε όλο τον κόσμο, οι οποίοι είναι διαθÎσιμοι, αλλά Ï€Ïιν ξεκινήσετε.
Lorem ipsum dolor sit amet, consectetur adipiscing elit. Nunc vel mi ac neque fringilla egestas ut sit amet felis. In malesuada lacinia ligula, quis tincidunt ante sollicitudin sed.
12351432123213';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);