using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s+[A-Ga-g](b|#|m|mi|min|M|maj|bm|#m|#mi|bmi|bmin|#min|sus|dim|[1-9]+)\s+";
string input = @"808—Bass Loop Dm 147bpm.wav
Drifting 100bpm F7 18.aif
120bpm Awakened Fdim.mp3
Rhodes 90bpm Am7sus4.ogg
01 Awakened 120bpm C#M9Gm9.caf";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}