import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s+[A-Ga-g](b|#|m|mi|min|M|maj|bm|#m|#mi|bmi|bmin|#min|sus|dim|[1-9]+)\\s+";
final String string = "808—Bass Loop Dm 147bpm.wav\n"
+ "Drifting 100bpm F7 18.aif\n"
+ "120bpm Awakened Fdim.mp3\n"
+ "Rhodes 90bpm Am7sus4.ogg\n"
+ "01 Awakened 120bpm C#M9Gm9.caf";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}