use strict;
my $str = '808—Bass Loop Dm 147bpm.wav
Drifting 100bpm F7 18.aif
120bpm Awakened Fdim.mp3
Rhodes 90bpm Am7sus4.ogg
01 Awakened 120bpm C#M9Gm9.caf';
my $regex = qr/\s+[A-Ga-g](b|#|m|mi|min|M|maj|bm|#m|#mi|bmi|bmin|#min|sus|dim|[1-9]+)\s+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}