# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(keep\d+\s*{[^}]*})|.+?/$1/gm;t' <<< "blah blah Bob Loblaw Law blah
keep1 { i want this } blop
blah blob keep2 { and
this too } blaw blat
ab ef"