import re
regex = re.compile(r"\b(keep\d+\s*{[^}]*})|.+?", flags=re.MULTILINE)
test_str = ("blah blah Bob Loblaw Law blah\n"
"keep1 { i want this } blop\n"
"blah blob keep2 { and\n"
"this too } blaw blat\n"
"ab ef")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)