use strict;
my $str = 'Баден&Баден
K&K
Top Top
Букет Букет Букет невесты Констанция
Букет,Букет Букет невесты Констанция
Top Top
D101, fdf1
ААА А АА А А А, Сумка 6030 Amethyst
1212, 3232
Букет100, невесты невесты& Букет невесты Жюльет
B2 fd B
xbckj 1 b xxbckj 2 f Njg100 Njg
в в
-B Конструктор Конструктор, Конструктор Chicco, Конструктор 5 в 1 Машины (40 деталей)
Баден&Баден
Букет Букет,
Баден-Баден
К & K
----
Дочки и Сыночки
2323-232-в
Инфа
Mert-Mert
Mert, Mert
D&D
1.1 ';
my $regex = qr/^([-\p{L}_&]+)[\s]+\1(\W)/ump;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}