# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([-\p{L}_&]+)[\s]+\1(\W)"
test_str = ("Баден&Баден \n"
"K&K\n"
"Top Top\n"
"Букет Букет Букет невесты Констанция\n"
"Букет,Букет Букет невесты Констанция\n"
"Top Top\n"
"D101, fdf1 \n"
"ААА А АА А А А, Сумка 6030 Amethyst\n"
"1212, 3232\n"
"Букет100, невесты невесты& Букет невесты Жюльет\n"
"B2 fd B \n"
"xbckj 1 b xxbckj 2 f Njg100 Njg \n"
"в в \n"
" -B Конструктор Конструктор, Конструктор Chicco, Конструктор 5 в 1 Машины (40 деталей)\n"
"Баден&Баден \n\n"
"Букет Букет,\n"
"Баден-Баден \n"
"К & K\n"
"----\n"
"Дочки и Сыночки\n"
"2323-232-в\n"
"Инфа\n\n"
"Mert-Mert \n"
"Mert, Mert\n"
"D&D\n"
"1.1 ")
matches = re.finditer(regex, test_str, re.UNICODE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.