#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)"(?:[^"]|"")*"|[^,\n]+|(?=,)(?<=,)|^|(?<=,)$"
Local $sString = "record 1:field 1,record 1:field 2,record 1:field 3" & @CRLF & _
"record 2:field 1,record 2:field 2,record 2:field 3" & @CRLF & _
""quoted field","quoted field, with comma", "whitespace before & affer quote" ,"new" & @CRLF & _
"line in field","double quotes ""in"" field","double quotes in field "","" with comma"" & @CRLF & _
",,,<- empty fields at beging, , ,<-whitespace fields,empty fields at end ->,," & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"^empty records"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")