using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/?t?e?s?t?/(\w+)+";
string input = @"/test/abc/123/klm/534/uuuu/342342";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}